WebMaker - Personal web site generator

Technical Manual

Design: | Transparent Systems Limited
Version: | 1.1
Last Updated on: | July 12, 2000


Table of Contents

Introduction
Feature list
System architecture
Installation of software
Software upgrade
Security
Anonymous logon

Home


Introduction

The purpose of WebMaker is to create a personalized web site online.
After entering some details WebMaker will generate a web site on the web server that can be viewed by a web browser instantly.
WebMaker is versatile yet easy to use.
A web master can set up any number of web templates.
The user can select a template to preview. After entering some details the web site is generated.
The system needs to know where on the web server it can put the web pages.
This is accomplished by registering a user.
The registration information is stored in a database on the web server.

The whole system is parameter driven. These parameters are stored in a parm.ini file.


Feature list

  1. User registration.
    The registration information is stored in a database.
  2. Logon.
    A user has to logon before creating a web site.
    WebMaker checks if the user is logged on.
    If not it will redirect the user to the logon page.
  3. Generation of personalized web site.
    After entering some details the system can generate a personalized web site on the web server.
    There is no need for the user to upload the web site from PC to web server.
  4. Several web pages available for user maintenance
    • Update user data
    • Change password
    • Mark user for deletion
  5. System can be integrated in ComReg.
    ComReg is an advanced user registration system that can be used separately or in combination with
    WebMaker. Adding ComReg to WebMaker has the advantage of simplified user and directory maintenance.


System architecture

System scheme
System description
Files

Table of Contents Next


System architecture: System scheme

Table of Contents System architecture Next


System architecture: System description

General
Security
Directories
Files

Table of Contents System architecture Next


System architecture: System description: General

WebMaker generates personalized web pages.
A user can select a web template.
There after the details can be entered.
When the user is ready entering all required fields the web site is generated on the address of the user.
The address is assigned to a user after registering.

The components required to run the system are:

  • Windows NT Server version 4.0
  • IIS version 4.0
  • ODBC
    The database is accessed using a Data Source Name
    You can assign a DSN via the ODBC manager


System architecture: System description: Security

WebMaker needs write access to the zones in which the web pages are generated.
This is accomplished by giving the anonymous logon user write access to each zone.

Table of Contents System architecture System description Next


System architecture: System description: Directories

cgi-bin
db
logon
webmaker

Table of Contents System architecture System description Next


System architecture: System description: Directories: cgi-bin

This directory contains general cgi programs.

echo.asp

Test utility to check application, session variables and cookies.
Note that cookies can be specific to a directory.
nexturl.asp
Utility to show next url. Can be called from any other ASP.


System architecture: System description: Directories: db

Contains register database register_db.mdb
The database is accessess using DAO (Data Access Objects).
DAO is installedwith IIS 4.0

Table of Contents System architecture System description Directories Next


System architecture: System description: Directories: logon

Sytem architecture: System description: Directories: logon

This directory contains programs to let a user logon to your web site.

logon.asp

Form to enter user id and password.


System architecture: System description: Directories: webmaker

System architecture: System descritpion: Directories: webmaker

Contains all files needed by WebMaker.

Table of Contents System architecture System description Directories Next


System architecture: Sytem description: Files

Register_db.mdb
Parm.ini in /webmaker
Parm.ini in /register

Table of Contents System architecture System description Next


System architecture: Sytem description: Files: Register_db.mdb

System architecture: System description: Files: Register_db.mdb

Stores data about user, zone and address

Table of Contents System architecture System description Files Next


System architecture: System description: Files: Parm.ini in /webmaker

Example of parm.ini

[General]
' RootURL=http://www.comreg.com
RootURL=http://WebMaker
' Street relative to root, for example /streets
StreetURL=
' Delimiter used in web template file to indicate a variable, like $variable$
Delimiter=$


System architecture: System description: Files: Parm.ini in/register

Example of parm.ini

[General]
RegisterDSN=Register
;RootURL=http://www.WebMaker.com
RootURL=http://WebMaker
;Zones virtual directory relative to root
ZonesURL=
HostAllowed=www.WebMaker.com;WebMaker;192.0.0.2;


Installation of software

Refer to install.txt for the latest installation instructions.
WebMaker.exe is a self extracting file that will put folders and files in a temporary directory.
Files have to be copied to your web site to a directory with the same name.

NOTE:
Use lowercase for all directories.
For example /register and not /Register.
This is because some browsers and cookies are case sensitive !

After having copied all files to your web site, test WebMaker with the installation templates.

  1. Register a new user
    Open browser and type http://www.comreg.com/register/register.asp
    Replace www.comreg.com by your site name.
  2. Start WebMaker
    Open browser and type http://www.comreg.com/webmaker/webmaker.asp
    WebMaker checks if you are logged on.
    If yes, you will see webmaker.asp
    If No, you will be prompted to log on.
    Type userid and password you just entered during the registration.
  3. Enter whatever details on webmaker.asp and submit the form.
    You get a confirmation page with a link to your personal web site.
    After clicking on the link you will see the web site that is generated.
After you have confirmed that the site is working, you can create your own web site templates.
Add new web templates to file webtemplatepreview.txt and webtemplate.txt.


Software upgrade

The system administrator can simply copy the files over existing files after receiving software upgrade.
Refer to installation of software.

Table of Contents Next


Security

The security of directories and files on the Internet server has to be set by the system administrator.

Table of Contents Next


Anonymous logon

The following table shows the permissions to be set for the Anonymous Logon user
By default this user is mapped on IUSR_
For example IUSR_NT1
Any browser gets all permissions and right of the Anonymous Logon user

Virtual Directory | Read | Write | Execute
/cgi-bin | X |  | X
/ | X |  |
/db | X | X |

Make sure that you set the correct permissions under both IIS and Windows NT.
Otherwise the ASP pages will not be able to create the web site.

Table of Contents


Table of Contents

Introduction
Feature list
System architecture
System scheme
System description
Installation of software
Software upgrade
Security
Anonymous logon

Home


Table of Contents

Introduction
Feature list
System architecture
System scheme
System description
General
Security
Directories
Files
Installation of software
Software upgrade
Security
Anonymous logon

Home


Table of Contents

Introduction
Feature list
System architecture
System scheme
System description
General
Security
Directories
cgi-bin
db
logon
webmaker
Files
Installation of software
Software upgrade
Security
Anonymous logon

Home


Table of Contents

Introduction
Feature list
System architecture
System scheme
System description
General
Security
Directories
Files
Register_db.mdb
Parm.ini in/webmaker
Parm.ini in/register
Installation of software
Software upgrade
Security
Anonymous logon

Home